/var/www/yatta47.log

やったのログ置場です。スクラップみたいな短編が多いかと。

cloud9にimagemagickインストールする

ImageMagick

よく使っているCloud9環境にImageMagickをインストールしようとしたらエラーが出たのでその備忘録。

 

発生現象

Cloud9はUbuntu環境なので、apt-get でインストールしようとしたら以下のエラーが発生。

yatta472:~/workspace $ sudo apt-get install imagemagick
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package imagemagick is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'imagemagick' has no installation candidate

普通に入ると思ったのにorz

 

apt-get updateが必要

公式のコミュニティで情報展開されていました。

community.c9.io

 

apt-get updateでレポジトリの更新が必要らしい。

$ sudo apt-get update

そのあとにインストールすれば入る。

$ sudo apt-get install imagemagick

インストールされたImageMagickのバージョンは以下。

yatta472:~/workspace $ convert --version
Version: ImageMagick 6.7.7-10 2017-07-31 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC
Features: OpenMP    

yatta472:~/workspace $ 

ImageMagickのバージョンってこれで見れるのか。知らなかった。

これでrubyでの画像処理が進められる。

Real Time Web Analytics